Service Disruption Whatsapp Integration

Incident Report for Webdox CLM

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 00:32 GMT-04:00

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 16, 2026 - 18:48 GMT-04:00

Investigating

We are experiencing intermittent issues with our WhatsApp integration. Our engineering team is currently working on a fix.
Posted Jun 16, 2026 - 18:10 GMT-04:00
This incident affected: Sites And Services - Americas (Webdox CLMS Signature).