A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 13:59 GMT-04:00
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 22, 2026 - 11:59 GMT-04:00
Investigating
We are investigating an issue affecting two-factor authentication (2FA) during login. Some users may be unable to complete authentication and access the platform. Our team is actively working on it.
Posted Jul 22, 2026 - 11:09 GMT-04:00
This incident affected: Sites And Services - Americas (Webdox CLMS Backend).