External Services : Provider [PE] - Verifik

Incident Report for Webdox CLM

Resolved

External Service Restored By Our Provider Verifik
Posted May 15, 2025 - 12:26 GMT-04:00

Monitoring

Monitoring Status Of External Service
Posted May 13, 2025 - 17:57 GMT-04:00

Update

We are continuing to work on a fix for this issue.
Posted May 13, 2025 - 17:55 GMT-04:00

Identified

External Identity Verification "Verifik" service for Peru Customers experiencing Degraded Performance
Posted May 12, 2025 - 13:27 GMT-04:00
This incident affected: External Services ([PE] - Verifik).