Brain - Performance Degradation

Incident Report for Webdox CLM

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 21:35 GMT-04:00

Update

We are continuing to monitor for any further issues.
Posted Jul 29, 2026 - 21:32 GMT-04:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 21:31 GMT-04:00

Identified

We are currently experiencing a service degradation performed by our external service provider. During this period, you may experience:

* Slower response times on certain features
* Intermittent service interruptions
* Limited availability of some functionality
Posted Jul 29, 2026 - 15:53 GMT-04:00
This incident affected: Sites And Services - Americas (Webdox CLMS Brain).