A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 12:36 GMT-04:00
Identified
External Services "Verifik" Response With Status Request timed out,This issue Ongoing monitoring in progress. Updates will be provided as they become available.
Posted Jul 28, 2025 - 08:51 GMT-04:00
Investigating
External Identity Verification "Verifik" service for Ecuador, Colombia and Peru Customers experiencing Degraded Performance