High Response Time

Incident Report for Webdox CLM

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 08:34 GMT-03:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2025 - 19:31 GMT-03:00

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 14:47 GMT-03:00
This incident affected: Sites And Services - Americas (Webdox CLMS FrontEnd, Webdox CLMS Backend).