External Services : Twilio SMS

Incident Report for Webdox CLM

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 15:07 GMT-04:00

Monitoring

We will continue to monitor, and will provide a further update once our upstream provider confirms that this issue has been fully resolved.
Posted Jun 24, 2025 - 14:09 GMT-04:00

Identified

Our external SMS service provider (Twilio) is experiencing degraded performance in SMS Delivery.

See:
https://status.twilio.com/incidents/2v9gl3g03g4k
Posted Jun 23, 2025 - 10:19 GMT-04:00
This incident affected: External Services (Twilio SMS).