High response times on some transactions

Incident Report for Webdox CLM

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 08:35 GMT-04:00

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 18:28 GMT-04:00

Monitoring

The infrastructure provider has identified and resolved the cause of the incident. Services have been restored in most regions and CSPs. (Cloud Service Providers) Users on GCP may experience minor impacts while we complete full recovery.

We continue to actively monitor. Upcoming updates available here.
Posted Jun 12, 2025 - 18:27 GMT-04:00

Update

Cloudflare has created a status post here https://www.cloudflarestatus.com/incidents/25r9t0vz99rp . You can follow that for more details on the incident.
Posted Jun 12, 2025 - 16:35 GMT-04:00

Update

GCP has created a status post here https://status.cloud.google.com/. You can follow that for more details on the incident.
Posted Jun 12, 2025 - 16:34 GMT-04:00

Identified

Service Incident - Status Update

Cloudflare Access: Cloudflare is actively investigating an issue causing Access authentication failures. This may impact access to protected applications and services.

Google Cloud Platform: Service disruptions have been reported across multiple GCP services, potentially affecting operations.
Status: Ongoing monitoring in progress. Updates will be provided as they become available.
Posted Jun 12, 2025 - 14:38 GMT-04:00

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 14:23 GMT-04:00
This incident affected: Sites And Services - Americas (Webdox CLMS FrontEnd, Webdox CLMS Backend, Webdox CLMS API, Webdox CLMS Signature, Webdox CLMS Preview, Webdox CLMS Third Party Collaboration, Webdox CLMS Brain, Webdox CLMS PowerBI, Webdox Biometria Backend, Webdox Biometria FrontEnd).