External Services : Twilio SMS

Incident Report for Webdox CLM

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 08:56 GMT-04:00

Update

We are continuing to monitor for any further issues.
Posted Jul 23, 2025 - 08:56 GMT-04:00

Monitoring

Third-Party External Provider Twilio Have Delivery delays when sending messages SMS to Middle East & Africa

see: https://status.twilio.com/
Posted Jul 17, 2025 - 10:37 GMT-04:00